ExPhylogeny

From teachingmaterials

Jump to: navigation, search

Contents

Exercise: Phylogeny

Written by Anders Gorm Pedersen, modified by Thomas S. Rask, Daniel Aaen Hansen and Rasmus Wernersson

Overview

This exercise has two parts. During the first (fairly small) part you will:

  1. Compare the performance of 3 different multiple alignment methods (mafft, muscle, clustalw) for aligning a set of proteins

During the second part you will:

  1. Perform a multiple alignment of gp120 protein sequences from HIV and SIV (using Clustal)
  2. Construct an unrooted tree from the alignment of gp120 sequences (using the "neighbor joining" algorithm in Clustal)
  3. Visualize the gp120-based tree using the program FigTree
  4. Consider the evolutionary implications of the gp120-based tree.
  5. Investigate the robustness of your tree by bootstrapping
  6. Perform a second multiple alignment based on POL protein sequences from HIV and SIV.
  7. Construct a new neighbor joining tree from the POL alignment
  8. Investigate whether the POL-based tree supports the conclusions from the gp120-based analysis
  9. Perform a multiple alignment of the same POL sequences and a POL sequence from HTLV-1.
  10. Root the POL-based tree using the HTLV sequence as an outgroup


Download and install ClustalX

In today's exercises, we will use the program Clustal to construct various multiple alignments. We have previously used the web-interface provided by EBI. Today we will use the program ClustalX and thus run the program on our own computer. Windows, Mac and Linux/Unix versions of the latest ClustalX version (v2.0.10) are freely available for download. ClustalX is a graphical front-end to the command line-based program ClustalW. The program is interactive with a typical, relatively user friendly, windows-style interface. ClustalX has online help available from the pull-down menu "Help".


Download from http://www.clustal.org the ClustalX package corresponding to your operating system. Make sure to download ClustalX and NOT ClustalW!


  • Windows: Download clustalx-2.0.10-win.msi
    • Double click the .msi file and follow the instructions to install the program.
    • Start ClustalX from the Start menu.


  • Mac (OSX only)
    • Download clustalx-2.0.10-macosx.dmg
    • Mount and open the downloaded .dmg file (unless it does so automatically).
    • Drag the clustalx program to your Applications folder in Finder. Open ClustalX from the Applications folder.


  • Linux/UNIX/SUN
    • Download clustalx-2.0.10-linux-i386-libcppstatic.tar.gz to the place where you want to install the program.
    • Change working directory to the folder where the downloaded .tar.gz file is located and unpack it using these two commands:
gunzip clustalx-2.0.5-linux-i386-libcppstatic.tar.gz

tar -xvf clustalx-2.0.5-linux-i386-libcppstatic.tar


Clustal X running on Macintosh

Comparison of multiple alignment programs

In this part of the exercise you will use a dataset of 11 alternatively-spliced gene products from the human erythrocyte membrane protein band 4.1 (EPB). In addition to the unaligned data set we also have a pre-aligned optimal alignment. The goal of this short exercise is to compare how well three different popular multiple alignment programs perform when attempting to align a set of proteins that are identical except for having different deletions.


Align the EPB sequences using mafft, muscle, and clustalw:

Construct three alignments, one from each of the servers linked below, by copy / pasting the unaligned set of EPB proteins. Use default settings on all servers. For each alignment, keep the window (or tab) open after use:


Data:


Servers:

  • ClustalW - Widely used progressive alignment method (web version of ClustalX)
  • MUSCLE - "MUltiple Sequence Comparison by Log-Expectation"
  • mafft - Multiple sequence alignment based on fast Fourier transform


Have a look at the original, unaligned data:

Open the unaligned set of EPB sequences ( EPB.fasta) in your local version of the ClustalX program and have a look (hint: first save the file to your disk, then open).

Note: In order to load sequences in ClustalX you do the following: In the "File" menu choose "Load sequences", and then select your fasta file in the proper directory.

In ClustalX the sequences are displayed on the screen with names on the left hand side, and the sequences themselves on the right. Residues are colored according to amino acid characteristics. It is possible to resize the window by "pulling" at the edges, so you can fit more lines in one window. A scroll-bar at the bottom of the window allows you to move along the alignment (in case the sequences are too long to fit in the horizontal direction).

Beneath the sequences there is a ruler starting at 1 for the first residue position. Below this is a graphical indication of the degree of conservation in each column of the alignment. A high score indicates a well-conserved column; a low score indicates low conservation. Since the sequences have not yet been aligned (they are all just lined up starting with their first residues), most values are quite low.

Recall that this is the unaligned set of sequences. NOTE: we are here only using clustalx as a sequence/alignment viewer, not as an alignment program.


Have a look at the optimally aligned data:

Now, open the prealigned, optimal alignment of the EPB sequences (EPB_IDEAL_alignment.fasta) in your local ClustalX program. Again drag your window and scroll along to see the entire alignment. Keep this window hanging around somewhere so you can compare the other alignments to it.

Have a look at the three different alignments: Compare the ideal alignment (shown in your local ClustalX program) to the three alignments you just constructed using the EBI servers (you can use either the JalView alignment viewer linked on the EBI result page, or your local ClustalX program for easier viewing. Note that for uncertain reasons there is no jalview link on the mafft page - you will here need to use ClustalX).

Question 1: Are the three alignments different? Which, if any, of the three alignment methods got the alignment entirely correct?

You should note that this was just one particular form of test. On a different problem the relative performance of the alignment methods could well be different. However, you should also note that this was a fairly simple problem, and one where you could easily see artefacts. That will not be the case for most real biological data sets.

Phylogeny of HIV

Background: AIDS, HIV1, HIV2, and SIV

Acquired Immune Deficiency Syndrome (AIDS) is caused by two divergent viruses, Human Immunodeficiency Virus one (HIV-1) and Human Immunodeficiency Virus two (HIV-2). HIV-1 is responsible for the global pandemic, while HIV-2 has, until recently, been restricted to West Africa and appears to be less virulent in its effects. Viruses related to HIV have been found in many species of non-human primates (monkeys, apes, ...) and have been named Simian Immunodeficiency Virus, SIV.

These primate viruses are lentiviruses, a subfamily of the retroviruses. Retroviruses have RNA genomes but are unique among RNA viruses because they have a replication cycle that involves the reverse transcription of their RNA genome into DNA (this is the opposite direction compared to the usual flow of information from DNA to RNA). The reverse-transcribed viral DNA is stably incorporated into the genomic DNA of an infected cell and subsequent transcription can then create multiple copies of mRNA encoding new viral material.


File:800px-HIV_Virion-en-2.png

Like other retroviruses, particles of HIV are made up of 2 copies of the single-stranded RNA genome packaged inside a protein core, or capsid. The core particle also contains viral proteins that are essential for the early steps of the virus life cycle, such as reverse transcription and integration. A lipid envelope, derived from the infected cell, surrounds the core particle. Embedded in this envelope are the surface glycoproteins of HIV: gp120; and, gp41. The gp120 protein is crucial for binding of the virus particle to target cells. It is the specific affinity of gp120 for the CD4 protein that targets HIV to those cells of the immune system that express CD4 on their surface (e.g., T-helper lymphocytes, monocytes, and macrophages).

The Pol gene is encoded by the RNA genome and encodes three different polypeptides: integrase, reverse transcriptase, and protease. It is expressed as a single polyprotein and is subsequently cleaved by protease into its three separate parts.

(more info at: http://en.wikipedia.org/wiki/HIV and http://en.wikipedia.org/wiki/Structure_and_genome_of_HIV)


Purpose of exercise, description of data

In this exercise you are going to investigate the phylogenetic relationship between HIV and SIV. You will do this using two different data sets:

  • a set consisting of 27 different gp120 protein sequences from isolates of HIV1, HIV2, chimpanzee SIV and macaque monkey SIV: gp120.fasta
  • a set consisting of 20 different POL-polyprotein sequences from HIV1, HIV2, chimpanzee SIV and sooty mangabey SIV: hiv-siv-pol.fasta; and the same set with the HTLV-1 sequence: htlv-hiv-siv-pol.fasta

Note for enthusiasts: a number of lines of evidence have indicated that macaques are not naturally infected with SIV and that they have acquired their SIV infection while in captivity by cross-species transmission of SIV from sooty mangabeys. This means that both the macaque SIVs and the sooty mangabey SIVs originate from sooty mangabeys.

Multiple alignment

Finally, the exercise

First, we will use the file gp120.fasta, which contains 27 gp120 envelope protein sequences from isolates of HIV-1, HIV-2, and SIV in fasta-format.

Download the gp120 file and take a look at its contents (using a text editor like jEdit).

In this file, all HIV-1 sequences have names starting HV1. All HIV-2 sequences have names starting HV2. SIVCZ was isolated from chimpanzee. SIVMK, SIVM1, and SIVML were isolated from macaques.


Open ClustalX program, load files

Discard all the previously opened browser- and ClustalX-windows and open a fresh ClustalX window on your own computer. Load the gp120.fasta file you just saved.

Have a look at the alignment parameters:

From the "Alignment" pull-down menu choose "Alignment parameters", and then "Pairwise alignment parameters". In this window you are able to change gap-penalties and substitution matrix for the initial, pairwise part of the multiple alignment.


QUESTION 2: Note the substitution matrix (Here "Protein Weight Matrix"), the gap opening penalty and the gap elongation penalty in your report.


You can also specify whether you want the pairwise alignments performed using a slower but accurate method, or a faster but approximate method. For now just leave everything as is and exit the window.

There is a similar window for changing the multiple alignment parameters ("Alignment", "Alignment parameters", "Multiple alignment parameters".) Have a look, but keep the default values for now.

Finally, there is also a window for changing a special set of gap parameters used by ClustalX ("Alignment", "Alignment parameters", "Protein gap parameters".).


QUESTION 3: Check what the parameters are set to in the "Protein gap parameters" window. Explanations of the various parameters are listed below

RESIDUE SPECIFIC PENALTIES: are amino acid specific gap penalties that reduce or increase the gap opening penalties at each position in the alignment or sequence. See the documentation for details. As an example, positions that are rich in glycine are more likely to have an adjacent gap than positions that are rich in valine.
HYDROPHILIC GAP PENALTIES are used to increase the chances of a gap within a run (5 or more residues) of hydrophilic amino acids; these are likely to be loop or random coil regions where gaps are more common. The residues that are "considered" to be hydrophilic can be entered in HYDROPHILIC RESIDUES.
GAP SEPARATION DISTANCE tries to decrease the chances of gaps being too close to each other. Gaps that are less than this distance apart are penalised more than other gaps. This does not prevent close gaps; it makes them less frequent, promoting a block-like appearance of the alignment.
END GAP SEPARATION treats end gaps just like internal gaps for the purposes of avoiding gaps that are too close (set by GAP SEPARATION DISTANCE above). If you turn this off, end gaps will be ignored for this purpose. This is useful when you wish to align fragments where the end gaps are not biologically meaningful.


Start the multiple alignment:

From the "Alignment" menu choose "Do complete alignment". This opens a window giving you the opportunity to rename output files. Make sure the files are named "gp120.dnd" and "gp120.aln" respectively (and that you keep track of where you save them on your computer), and start the alignment by clicking "OK".

You may be able to get a glimpse of how ClustalX is working in the bottom part of the window: first, it does all the pairwise alignments. These alignments are then used to construct a "guide tree". (The guide tree should not be confused with the phylogenetic tree we will construct later. The guide tree is entirely based on the pairwise alignments, and is used to guide the construction of the multiple alignment). Finally, ClustalX constructs the multiple alignment by progressively "aligning algnments" following the guide tree.


Inspect the alignment:

When the alignment is done you can inspect the result by scrolling along the sequences in the ClustalX window. You will notice that the conservation graph at the bottom of the window now has several peaks and plateaus corresponding to the conserved regions of gp120. An additional summary of conservation is given above the sequences. "*" indicates positions which have a single, fully conserved residue, ":" indicates positions with strong functional conservation, and "." indicates positions with weaker functional conservation. Don't close ClustalX after inspecting the alignment (you can iconize it if it clutters the screen).

Computing an unrooted tree

In this part of the exercise we will use ClustalX to produce a phylogenetic tree. The tree is built with the neighbour joining algorithm, and is based on distances computed from the multiple alignment you just constructed.


Now return to your alignment of gp120

(Don't panic if you accidentally closed the ClustalX program after the multiple alignment: start the program as before, and use "File", "Load sequences" to load the alignment file: "gp120.aln")


Select output of treefile and distance matrix:

From the "Trees" menu choose "Output format options" and select "PHYLIP format tree" and "PHYLIP distance matrix". Click "OK".


Construct the tree:

From the "Trees" menu choose "Clustering Algorithm" and make sure "NJ" is selected. Then, from the "Trees" menu choose "Draw Tree". This gives you a window where you can change the name of the tree-file and the distance matrix. Make sure they are named "gp120.ph" and "gp120.dst" respectively, and then click "OK" to calculate the tree. ClustalX uses the multiple alignment to calculate a distance matrix with all pairwise distances between the 27 sequences, and then constructs a tree by progressively clustering sequences that are close to each other (using the neighbor-joining algorithm). (Note: the construction of the NJ-tree is so fast that its practically finished the second you have clicked "Draw Tree" - so no need to sit around and wait for the result).


Inspect the output files:

The tree you just computed has been saved on your computer under the name gp120.ph. Use a text editor like jEdit to open the file and have a look. This treefile is in a text-based format that is obviously mostly meant for computers. Also look at the file containing all pairwise distances between all sequences: gp120.dst.

These are the numbers that were used by the neighbor joining algorithm for constructing the tree. For each sequence the distance to all other sequences are listed on a number of consecutive lines (there are too many distances to fit on a single line). The format is such that you should imagine a table where the order on the (unlabeled) horizontal axis is the same as on the vertical axis (i.e., the first sequence is HV1EL, the second is HV1Z2, etc.)


QUESTION 4: Scroll down to the entry for the sequence named HV2BE. Note the first and last distances on the results form (these are the distances to the sequences HV1EL and SIVM1, respectively).


View a plot of the unrooted tree:

There are several programs for visualizing tree-files like the PHYLIP-file gp120.ph. Today we will use the program FigTree version 1.2, which can be downloaded from here: http://tree.bio.ed.ac.uk/software/figtree/.


Download, install and start FigTree
Download the FigTree program corresponding to your operating system:
  • Windows: Download FigTree v1.2.zip
Unzip the downloaded .zip file and doubleclick the .exe file to run FigTree.


  • Mac OSX: Download FigTree v1.2.dmg
Mount and open the downloaded .dmg file (unless it does so automatically).
Drag the FigTree v1.1.2 program to your Applications folder in Finder.
Open FigTree from the Applications folder.


  • Linux/UNIX/SUN: Download FigTree.v1.2.tgz to the place where you want to install the program.
Change working directory to the folder where the downloaded .tgz file is located and unpack it using these two commands:


gunzip FigTree.v1.2.tgz
tar -xvf FigTree.v1.2.tar


The program files have now been unpacked and are ready to run. Start FigTree with the following command:


java -Xms64m -Xmx128m -jar FigTree.v1.2/figtree.jar &


This opens the program in a separate window. Be sure to include the "&" which will make the program run in the background, so we can start more programs from the same shell window.


NOTE: FigTree requires Java to run. If you don't have Java installed, you can get it from here.
Also note that the Java version of FigTree (see Linux/UNIX/SUN above) can actually be used on any operating system with Java installed (including Winsows and Mac OSX).


Load the PHYLIP file in FigTree
On some operating systems, FigTree starts out by asking for a tree file. If FigTree doesn't ask for a tree file select "Open..." from the "File" menu. Select the gp120.ph file.
Under "Layout" in the column to the left, select the button furthest to the right with an unrooted tree on it ("Radial Tree Layout"). As our tree has not yet been rooted it is only appropriate to visualize it as unrooted. You can enlarge the Tip labels under "Tip labels"->"Set: Font"-> "size" if necessary.


QUESTION 5: Include a screenshot of the tree in your report (or create a separate file for this) and indicate where the HIV1 cluster, the HIV2 cluster, the SIVCZ sequence, and the SIVMK sequences are located.


Think for a minute about the implications:

What does this tree tell us about the phylogenetic relationship of HIV-1, HIV-2 and SIV? Notice especially where the two different groups of SIV cluster compared to the two different groups of HIV.

When you've thought about the problem, you can read a brief explanation that I've prepared. Additionally, you can find a good description of HIV evolution here: Diversity and Evolution of Primate Lentiviruses

Bootstrapping a neighbor joining tree

ClustalX also has the possibility of bootstrapping your neighbor joining tree:

Reopen your alignment from before (described above) and In the Trees menu choose "Output Format Options", and set Bootstrap labels to NODE. This will allow FigTree (and TreeViewer) to visualize the bootstrap values, as it does not recognize bootstrap labels in PHYLIP files where the labels are located on branches.

Setting the bootstrap output options

In the Trees menu choose "Bootstrap NJ-tree". This gives you a window where you can change the number of resampled data sets. The default is 1000, but you may want to change this to 100 in order not to wait for too long. Make sure the tree file will be named "gp120.phb" and click OK to start the bootstrapping

The idea in bootstrapping is to assess how much support there is for each branch in your tree, based on the data at hand. Imagine you have an alignment with 135 columns. ClustalX performs bootstrapping by randomly picking a column 135 times in a row, thereby generating a new permuted alignment having the same size as the original alignment (135 columns). A column may be chosen more than once (this is normally termed "sampling with replacement"). In the newly generated, permuted alignment some columns will be present multiple times, while some of the original columns will be absent.

This sampling with replacement is done a large number of times (usually 500-1000), so that a lot of permuted alignments are produced. For each of these alignments a tree is now constructed using neighborjoining. Finally, a consensus tree is made from the large set of trees. Basically the consensus tree consists of the taxonomic (monophyletic) groups that occur most frequently in the large set of trees.

The consensus tree that is produced has a number on each internal branch indicating how well supported that branch is (larger is better). Specifically, the number indicates how many of the individual trees in the large tree-set that contained that particular branch. (It is perhaps useful to think of each internal branch as defining a bi-partition of the leafs. If two different trees each possess an internal branch that divides the leafs into, say, one group with leaf A, B, and C, and another group with leaf D and E, then both trees are said to have the same internal branch).

It has been found that the variation you get as a result of this type of bootstrapping is similar to what you get when collecting new data, and it therefore gives you an idea about how well supported the individual branches in your tree are. It is, however, not a real significance or probability (for that purpose you might want to use Bayesian phylogeny which we will, however, not discuss in this course).


View the bootstrapped tree: File:Creen_shot_2010-04-06_at_4.45.52_PM.png

Load the gp120.phb file in FigTree and name the input "Bootstrap values".

Make sure that "Branch labels" are check-marked to the left and open the "Branch labels" menu (see picture). Make sure that "Display" is set to "Bootstrap values" under this menu. You should now be able to see the tree with the values attached to all internal branches. Remember that the number tells how often the data was divided into the two groups present on either side of the branch. Please note that this is still an unrooted tree so you may still want to view it in the unrooted layout.

QUESTION 6: What is the bootstrap value on the internal branch separating the HIV1/SIVCZ cluster from the HIV2/SIVMK cluster?

Rooting a tree using an outgroup

In this part of the exersize you will use a data set of 20 different POL-polyprotein sequences isolated from HIV-1, HIV-2, chimpanzee SIV, and sooty mangabey SIV. The Pol gene encodes three different polypeptides: integrase, reverse transcriptase, and protease. It is expressed as a single polyprotein and is subsequently cleaved by protease into its three separate parts.

First, you will construct a neighbor-joining tree like before and investigate whether this new, independent data set confirms the conclusions you made based on the alignment of gp120 sequences. Then you will add a POL-polyprotein sequence from HTLV-1 to the data set and construct a new tree, that you can then root using the HTLV sequence as an outgroup. (HTLV-1 is another member of the family of retroviruses and is thus more distantly related to HIV - which was originally named HTLV-3 by the way)


Download and have a look at the POL sequence file:

Download the hiv-siv-pol.fasta file, and inspect the alignment with a text editor.

As mentioned, this file contains POL-polyprotein sequences from HIV-1, HIV-2, chimpanzee SIV, and sooty mangabey SIV.


Align the POL sequences using ClustalX:

Re-open the ClustalX window and load the sequence file hiv-siv-pol.fasta. Now, start the alignment by choosing "Do complete alignment" from the "Alignment" menu as before.


Construct a neighbor-joining (NJ) tree with no outgroup:

Make sure "Clustering Algorithm" is set to "NJ". From the "Trees" menu choose "Draw Tree". Make sure the tree will be named "hiv-siv-pol.ph".


Inspect the unrooted tree:

Open FigTree and load the PHYLIP tree file hiv-siv-pol.ph.

This tree has been constructed from an entirely independent set of sequences. Does it support the conclusions that could be made from the gp120-based tree? (again, remember to use the unrooted layout).


QUESTION 7: Create a screenshot (again you may create a new file for this) indicating the position of the HIV1-cluster, the HIV2-cluster, the HIVCZ sequence and the HIVSmanga sequences.


Have a look at the POL sequence file with an added outgroup:

Download the htlv-hiv-siv-pol.fasta file, and inspect the data set with a text editor.

This file contains the same sequences as the file hiv-siv-pol.fasta plus an additional POL-sequence from the related virus HTLV-1 (the first sequence in this file). The HTLV POL sequence will be used as an outgroup in this part of the exercise.


Align the outgroup-containing data set using ClustalX and create neighbor-joining tree:

Re-open the ClustalX window and load the sequence file htlv-hiv-siv-pol.fasta.

Now, start the alignment by choosing "Do complete alignment" from the "Alignment" menu as before.

From the "Trees" menu choose "Draw Tree" (make sure that clustering algorithm is set to "NJ"). Make sure the tree will be named "htlv-hiv-siv-pol.ph".


Inspect the unrooted tree:

Load the treefile htlv-hiv-siv-pol.ph in FigTree, and in the Layout menu choose the button furthest to the right, with the unrooted tree on it.

Observe how the outgroup HTLV is located quite distantly from the other sequences.


Root the tree by using an outgroup:

We will now construct a rooted tree, using the HTLV sequence as an outgroup. The outgroup will be used to place the root of the tree.

The rationale is as follows: our data set consists of sequences from HIV-1, HIV-2, SIV and HTLV. We know from other evidence that the lineage leading to HTLV branched off before any of the remaining viruses diverged from each other. The root of the tree connecting the organisms investigated here, must therefore be located between the HTLV sequence (the "outgroup") and the rest (the "ingroup"). This way of finding a root is called "outgroup rooting", and constructs a tree where the outgroup is a monophyletic sister group to the ingroup.

In FigTree select the branch leading to the HTLV sequence by clicking on it.

In the "Tree" menu choose "Root on Branch...". This places the root on the branch leading to the HTLV sequence. But we won't see any change since the tree is being viewed as an unrooted tree.

In the "Layout" option choose the button furthest to the left to view the tree as a rooted tree.


QUESTION 8: On the screenshot you made before, indicate which branch the root is located on. Was this were you expected it?

Personal tools